The Fulcrum mobile data collector app is available on both Google’s Play Store and Apple’s App Store.

Our support strategy is to support respective operating systems that device vendors support and ensure that many of our current users can benefit from continuous Fulcrum app updates.

Fulcrum app requirements for mobile operating systems

  • Android Operating System: 8+ (Current + 5 prior releases)

  • iOS Operating System: 14+ (Current + 2 prior releases)

Fulcrum app version requirements

To remain operational, mobile devices MUST be running the most recent version of the Fulcrum app within 3 months of its release. Updates are typically released twice per month.

Did this answer your question?