Fulcrum can be run on devices running Android 4.1 (Jelly Bean) or higher and iOS versions 11.0 or higher

The Fulcrum mobile app can be downloaded for Android devices through the Play Store

For iOS users, Fulcrum can be downloaded from the iTunes Store.

Note for Android users: In addition to the device running Android 4.4 or higher, the Android device must have Google Play Services installed. If your device can access the Google Play Store, then it should have Google Play Services.

Notes: In addition to the above requirements the device must support TLS 1.2 or higher. This can vary from device to device but a majority of newer device will support this operating level. The following site can be used as a general guide to check whether your device may be compatible. https://support.globalsign.com/ssl/general-ssl/tls-protocol-compatibility

Did this answer your question?